Saturday, November 13, 2010

Mac OS X Disable Unnecessary Services

SkyHi @ Saturday, November 13, 2010
How do I disable unnecessary services under Mac OS X to secure my Mac OS X based desktop / server / laptop?

Mac OS X use the following directories to start various services (quoting from the man page):
  1. /System/Library/LaunchDaemons/ - System-wide daemons provided by Mac OS X
  2. /System/Library/LaunchAgents/ - Per-user agents provided by Mac OS X.
  3. ~/Library/LaunchAgents/ - Per-user agents provided by the user.
  4. /Library/LaunchAgents/ - Per-user agents provided by the administrator.
  5. /Library/LaunchDaemons/ - System-wide daemons provided by the administrator.
launchd manages processes, both for the system as a whole and for individual users using .plist files. Open the terminal and type the following commands to view directory files:
cd /System/Library/LaunchDaemons/
ls -l
ls -l | less
OR
cd /System/Library/LaunchAgents/
ls -l
ls -l | less

How Do I Disable Unnecessary Services?

You need to use the launchctl command as follows:
sudo launchctl unload -w /path/to/.plist/file
sudo launchctl unload -w /System/Library/LaunchDaemons/file.plist
In this example, you are disabling the Bonjour service, enter:
sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist
sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.mDNSResponderHelper.plist

 

If you don’t fancy using the shell then there’s a GUI tool called Lingon…
http://sourceforge.net/projects/lingon/files/

 

References:

  • launchctl(1) man page.
  • http://www.cyberciti.biz/faq/disabling-unnecessary-mac-osx-services/